summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorIvan Kohler <ivan@freeside.biz>2024-07-16 09:01:05 -0700
committerIvan Kohler <ivan@freeside.biz>2024-07-16 09:01:05 -0700
commiteca9fd0d0f2594489cf4a85a0669caeeb51328ec (patch)
tree86dd8e62e024b4c342e2a5a3bb3423e889c40fcf /debian
parenteabe4bcb022bfede9c0f9393109976293cbfd9c3 (diff)
systemd: start apache after postgresqlHEADmaster
Diffstat (limited to 'debian')
-rw-r--r--debian/freeside-webui.dirs2
-rwxr-xr-xdebian/rules4
2 files changed, 3 insertions, 3 deletions
diff --git a/debian/freeside-webui.dirs b/debian/freeside-webui.dirs
index 216d42de8..c66d55a23 100644
--- a/debian/freeside-webui.dirs
+++ b/debian/freeside-webui.dirs
@@ -1,2 +1,2 @@
/usr/local/etc/freeside/profile
-/etc/systemd/system/apache2.d
+/etc/systemd/system/apache2.service.d
diff --git a/debian/rules b/debian/rules
index 928e589eb..b3240880a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -133,7 +133,7 @@ install-stamp: build-stamp
install -d $(FREESIDE_DOCUMENT_ROOT)
install -d $(TMP)-webui/usr/local/etc/freeside/
- install -d $(TMP)-webui/etc/systemd/system/apache2.d/
+ install -d $(TMP)-webui/etc/systemd/system/apache2.service.d/
install -d $(TMP)/usr/local/etc/freeside/
# install -d $(TMP)-lib/usr/bin
@@ -176,7 +176,7 @@ install-stamp: build-stamp
# Create Apache configurations
install -d $(APACHE_CONF)
$(MAKE) -e DESTDIR=$(APACHE_CONF) install-apache
- install -o root -m 755 init.d/systemd-apache-override.conf $(TMP)-webui/etc/systemd/system/apache2.d/override.conf
+ install -o root -m 755 init.d/systemd-apache-override.conf $(TMP)-webui/etc/systemd/system/apache2.service.d/override.conf
#Hack the build dir out of apache config