This commit was generated by cvs2svn to compensate for changes in r4407,
[freeside.git] / rt / configure.ac
index 04f3d83..1d0b95f 100644 (file)
@@ -1,12 +1,13 @@
+autoconf; exec ./configure $@
 dnl
 dnl Process this file with autoconf to produce a configure script
 dnl
 dnl Embed in generated ./configure script the following CVS info:
-AC_REVISION($Revision: 1.1.1.3 $)dnl
+AC_REVISION($Revision: 1.1.1.5 $)dnl
 
 dnl Setup autoconf
 AC_PREREQ(2.53)
-AC_INIT(RT, [3.0.12], [rt-3.0-bugs@fsck.com])
+AC_INIT(RT, [3.4.4], [rt-bugs@fsck.com])
 AC_CONFIG_SRCDIR([lib/RT.pm.in])
 
 dnl Extract RT version number components
@@ -27,6 +28,8 @@ AC_PATH_PROG([PERL], [perl], [not found])
 if test "$PERL" = 'not found'; then
        AC_MSG_ERROR([cannot use $PACKAGE_NAME without perl])
 fi
+
+
 dnl SPEED_BIN
 AC_ARG_WITH(speedycgi,
            AC_HELP_STRING([--with-speedycgi=/path/to/speedy],
@@ -40,18 +43,38 @@ dnl Defaults paths for installation
 AC_PREFIX_DEFAULT([/opt/rt3])
 RT_ENABLE_LAYOUT
 
-dnl RTGROUP
-AC_ARG_WITH(rt-group,
-           AC_HELP_STRING([--with-rt-group=GROUP],
-                          [group to own all files (default: rt)]),
-            RTGROUP=$withval,
-            RTGROUP=rt)
-AC_SUBST(RTGROUP)
+
+# ACRT_USER_EXISTS( users, variable, default )
+# - users is a list of users [www apache www-docs]
+#    from highest to lowest priority to high priority (i.e. first match)
+# - variable is what you set with the result
+#
+
+AC_DEFUN([ACRT_USER_GUESS],
+ [ 
+   $2=$3
+   for x in $1; do
+    AC_MSG_CHECKING([if user $x exists]) 
+     AS_IF([ $PERL -e"exit( defined getpwnam('$x') ? 0 : 1)" ],
+           [ AC_MSG_RESULT([found]); $2=$x ; break],
+           [ AC_MSG_RESULT([not found]) ])
+   done
+  ])
+AC_DEFUN([ACRT_GROUP_GUESS],
+ [ 
+   $2=$3
+   for x in $1; do
+    AC_MSG_CHECKING([if group $x exists]) 
+     AS_IF([ $PERL -e"exit( defined getgrnam('$x') ? 0 : 1)" ],
+           [ AC_MSG_RESULT([found]); $2=$x ; break],
+           [ AC_MSG_RESULT([not found]) ])
+   done
+  ])
 
 dnl BIN_OWNER
 AC_ARG_WITH(bin-owner,
            AC_HELP_STRING([--with-bin-owner=OWNER],
-                          [user that will own rt binaries (default root)]),
+                          [user that will own RT binaries (default root)]),
             BIN_OWNER=$withval,
             BIN_OWNER=root)
 AC_SUBST(BIN_OWNER)
@@ -67,7 +90,7 @@ AC_SUBST(LIBS_OWNER)
 dnl LIBS_GROUP
 AC_ARG_WITH(libs-group,
            AC_HELP_STRING([--with-libs-group=GROUP],
-                          [group that will own rt binaries (default bin)]),
+                          [group that will own RT binaries (default bin)]),
             LIBS_GROUP=$withval,
             LIBS_GROUP=bin)
 AC_SUBST(LIBS_GROUP)
@@ -75,20 +98,26 @@ AC_SUBST(LIBS_GROUP)
 dnl DB_TYPE
 AC_ARG_WITH(db-type,
            AC_HELP_STRING([--with-db-type=TYPE],
-                          [sort of database RT will use (default: mysql) (mysql, Pg, Oracle and Informix are valid)]), 
+                          [sort of database RT will use (default: mysql) (mysql, Pg, Oracle, Informix and SQLite are valid)]), 
             DB_TYPE=$withval,
             DB_TYPE=mysql)
-if test "$DB_TYPE" != 'mysql' -a "$DB_TYPE" != 'Pg' -a "$DB_TYPE" != 'SQLite' -a "$DB_TYPE" != 'Oracle' -a "$DB_TYPE" != 'Informix' ; then
-       AC_MSG_ERROR([Only Oracle, Informix, Pg and mysql are valid db types])
+if test "$DB_TYPE" != 'mysql' -a "$DB_TYPE" != 'Pg' -a "$DB_TYPE" != 'SQLite' -a "$DB_TYPE" != 'Oracle' -a "$DB_TYPE" != 'Informix' -a "$DB_TYPE" != 'Sybase' ; then
+       AC_MSG_ERROR([Only Oracle, Informix, Pg, mysql and SQLite are valid db types])
 fi
 AC_SUBST(DB_TYPE)
 
-dnl ORACLE_ENV_PREF
+dnl DATABASE_ENV_PREF
 if test "$DB_TYPE" = 'Oracle'; then
        test "x$ORACLE_HOME" = 'x' && AC_MSG_ERROR([Please declare the ORACLE_HOME environment variable])
-       ORACLE_ENV_PREF="\$ENV{'ORACLE_HOME'} = '$ORACLE_HOME';"
+       DATABASE_ENV_PREF="\$ENV{'ORACLE_HOME'} = '$ORACLE_HOME';"
+fi
+
+dnl DATABASE_ENV_PREF
+if test "$DB_TYPE" = 'Sybase'; then
+       test "x$SYBASE" = 'x' && AC_MSG_ERROR([Please declare the SYBASE_HOME environment variable])
+       DATABASE_ENV_PREF="\$ENV{'SYBASE'} = '$SYBASE';"
 fi
-AC_SUBST(ORACLE_ENV_PREF)
+AC_SUBST(DATABASE_ENV_PREF)
 
 dnl DB_HOST
 AC_ARG_WITH(db-host,
@@ -151,29 +180,58 @@ AC_ARG_WITH(web-user,
            AC_HELP_STRING([--with-web-user=USER],
                           [user the web server runs as (default: www)]),
             WEB_USER=$withval,
-            WEB_USER=www)
+            ACRT_USER_GUESS([www www-data apache httpd nobody],[WEB_USER],[www])
+)
 AC_SUBST(WEB_USER)
 
 dnl WEB_GROUP
 AC_ARG_WITH(web-group,
-            AC_HELP_STRING([--with-web-group=GROUP],
+           AC_HELP_STRING([--with-web-group=GROUP],
                           [group the web server runs as (default: www)]),
             WEB_GROUP=$withval,
-            WEB_GROUP=www)
+            ACRT_GROUP_GUESS([www www-data apache httpd nogroup nobody],[WEB_GROUP], [www]))
 AC_SUBST(WEB_GROUP)
 
+dnl RTGROUP
+AC_ARG_WITH(rt-group,
+           AC_HELP_STRING([--with-rt-group=GROUP],
+                          [group to own all files (default: rt)]),
+            RTGROUP=$withval,
+            ACRT_GROUP_GUESS([rt3 rt $WEB_GROUP],[RTGROUP], [rt]))
+AC_SUBST(RTGROUP)
+
 dnl INSTALL AS ME
 my_group=$(groups|cut -f1 -d' ')
+my_user=${USER:-$LOGNAME}
 AC_ARG_WITH(my-user-group,
             AC_HELP_STRING([--with-my-user-group],
                            [set all users and groups to current user/group]),
             RTGROUP=$my_group
-            BIN_OWNER=$USER
-            LIBS_OWNER=$USER
+            BIN_OWNER=$my_user
+            LIBS_OWNER=$my_user
             LIBS_GROUP=$my_group
-            WEB_USER=$USER
+            WEB_USER=$my_user
             WEB_GROUP=$my_group)
 
+
+
+dnl Set the value of apachectl
+AC_ARG_WITH(apachectl,
+            AC_HELP_STRING([--with-apachectl],
+                           [instruct RT where to find your apachectl]),
+
+            APACHECTL=$withval, 
+            APACHECTL=`which apachectl`)
+AC_SUBST(APACHECTL)
+
+dnl RT's "maintainer mode"
+AC_ARG_WITH(devel-mode,
+            AC_HELP_STRING([--with-devel-mode],
+                           [Turn on development aids that might hurt you in production]),
+
+            RT_DEVEL_MODE="1", 
+            RT_DEVEL_MODE="0")
+AC_SUBST(RT_DEVEL_MODE)
 dnl This section maps the variable names this script 'natively' generates
 dnl to their existing names. They should be removed from here as the .in
 dnl files are changed to use the new names.
@@ -206,24 +264,26 @@ AC_SUBST([RT_LOG_PATH],                   ${exp_logfiledir})
 
 dnl Configure the output files, and generate them.
 
+dnl Binaries that should be +x
 AC_CONFIG_FILES([
+                sbin/rt-dump-database
                 sbin/rt-setup-database
-                 sbin/rt-test-dependencies
-                 Makefile
-                etc/RT_Config.pm
-                lib/RT.pm
-                 lib/t/00smoke.t
-                 lib/t/01harness.t
-                 lib/t/02regression.t
-                 lib/t/03web.pl
-                 lib/t/04_send_email.pl
+                sbin/rt-test-dependencies
                 bin/mason_handler.fcgi
                 bin/mason_handler.scgi
-                bin/mason_handler.svc
-                bin/rt-commit-handler
+                bin/standalone_httpd
                 bin/rt-crontool
                 bin/rt-mailgate
-                bin/rt
-                bin/webmux.pl]
-                )
+                bin/rt],
+               [chmod ug+x $ac_file]
+               )
+
+dnl All other generated files
+AC_CONFIG_FILES([
+                Makefile
+                etc/RT_Config.pm
+                lib/RT.pm
+                bin/mason_handler.svc
+                bin/webmux.pl],
+               )
 AC_OUTPUT