fix week expand / collapse images under RT 4.2, RT#34237, RT#13852
[freeside.git] / debian / rules
index f390072..e7f5bd8 100755 (executable)
@@ -78,6 +78,8 @@ export FREESIDE_URL           = http://$(HOSTNAME)/freeside/
 # (but leaving it for now, otherwise can't get RT to put files where we need em)
 export RT_PATH                = $(TMP)/opt/rt3
 
+export TEXMF_PATH             = $(TMP)-lib/usr/local/share/texmf/tex/latex
+
 # This has to be exported to make some magic below work.
 export DH_OPTIONS
 
@@ -167,9 +169,8 @@ install-stamp: build-stamp
        $(MAKE) -e DESTDIR=$(TMP)-webui install-docs
        
        # Install tex
-       install -D -o freeside -m 444 etc/longtable.sty \
-       $(TMP)-lib/usr/local/share/texmf/tex/latex/longtable.sty
-       texhash $(TMP)-lib/usr/local/share/texmf
+       install -d ${TEXMF_PATH}
+       install -o freeside -m 444 etc/*.sty ${TEXMF_PATH}
 
        # Create Apache configurations
        install -d $(APACHE_CONF)
@@ -265,6 +266,7 @@ install-stamp: build-stamp
        install -d $(RT_PATH)/share
 
        ( cd rt; $(MAKE) config-install dirs files-install fixperms instruct )
+       cp -r ${RT_PATH}/share/static/images ${FREESIDE_DOCUMENT_ROOT}/rt/NoAuth/
        
        ##hack the build dir out of RT.  yeah, sucky.