Debian packages
[freeside.git] / debian / rules
index c658278..07d3914 100755 (executable)
@@ -15,7 +15,7 @@ TMP     = $(CURDIR)/debian/$(PACKAGE)
 #DBC_SCRIPTS = $(TMP)/usr/share/dbconfig-common/scripts/freeside
 
 ##this is gotten from dbconfig-common
-#DB_TYPE = db_type_is_configured_during_pkg_install_by_dbconfig-common_not_at_build_time
+DB_TYPE = Pg
 
 #Data source
 DATASOURCE = DBI:${DB_TYPE}:dbname=freeside
@@ -93,8 +93,8 @@ build-stamp:
        dh_testdir
        # Add commands to compile the package here
        
-       ( cd FS/ && $(PERL) Makefile.PL PREFIX=$(TMP)-lib/usr INSTALLDIRS=vendor && [ -e Makefile ] || perl Makefile.PL && make )
-       
+       ( cd FS/ && $(PERL) Makefile.PL INSTALLDIRS=vendor && $(MAKE) )
+       $(MAKE) perl-modules    
        #install this for freeside-setup
        install -d $(DIST_CONF)
        install `ls -d conf/[a-z]* | grep -v CVS | grep -v '^conf/registries'` $(DIST_CONF)
@@ -125,10 +125,10 @@ install-stamp: build-stamp
        # debian/<package>-whatever.
 
        install -d $(FREESIDE_DOCUMENT_ROOT)
-       install -d $(TMP)-lib/usr/bin/
        install -d $(TMP)-webui/usr/local/etc/freeside/
        install -d $(TMP)/usr/local/etc/freeside/
        install -d $(FREESIDE_CACHE)/masondata #MASONDATA
+#      install -d $(TMP)-lib/usr/bin
 
        ( cd FS/ && $(MAKE) -e DESTDIR=${TMP}-lib install)
 
@@ -195,6 +195,7 @@ install-stamp: build-stamp
        perl -p -i -e "\
           s'${TMP}?''g;\
         " ${TMP}-lib/usr/bin/* \
+         ${TMP}-webui/usr/local/etc/freeside/handler.pl
 
        #RT Config