no longer supporting deb7
[freeside.git] / bin / freeside-debian-releases.sh
index ed4c005..f5f1e89 100644 (file)
@@ -22,9 +22,6 @@ fi
 
 GIT_VERSION=`grep '^$VERSION' $DIR/freeside/FS/FS.pm | cut -d\' -f2`
 
-# Clean configuration file
-rm -fr $DIR/freeside/debian/freeside-ng-selfservice.conffiles
-
 # Pull any changes
 cd $DIR/freeside
 git checkout -- debian/changelog
@@ -45,8 +42,11 @@ pdebuild --pbuilderroot sudo --debbuildopts "-b -rfakeroot -uc -us" --buildresul
 cd $DIR && rm -f freeside_*
 cd $TARGET && rm -f *.gz
 
-apt-ftparchive -qq packages ./ | gzip >Packages.gz
-apt-ftparchive -qq sources ./ | gzip >Sources.gz
-apt-ftparchive -qq packages ./ | bzip2 >Packages.bz2
-apt-ftparchive -qq sources ./ | bzip2 >Sources.bz2
+apt-ftparchive -qq packages ./ >Packages
+gzip -c Packages >Packages.gz
+#bzip2 -c Packages >Packagez.bz2
+apt-ftparchive -qq sources ./ >Sources
+gzip -c Sources >Sources.gz
+#bzip2 -c Sources >Sources.bz2
+rm *bz2 || true
 apt-ftparchive -qq release ./ >Release