RT# 74523 - Moved bin/cdr-fusionpbx.import to FS/bin/freeside-cdr-freeswitch
[freeside.git] / bin / freeside-debian-releases.sh
index 8246526..c774dd8 100755 (executable)
@@ -27,7 +27,9 @@ rm -fr $DIR/freeside/debian/freeside-ng-selfservice.conffiles
 
 # Pull any changes
 cd $DIR/freeside
-STATUS=`git pull`
+git checkout -- debian/changelog
+git pull
+#STATUS=`git pull`
 
 #Assign the proper config files for freeside-ng-selfservice
 if [ $DISTRO = "wheezy" ]; then
@@ -37,8 +39,9 @@ else
 fi
 
 # Add the build information to changelog
-
-dch -b --newversion $GIT_VERSION~$DATE "Auto-Build"
+if [ $FS_REPO != "stable" ]; then
+       dch -b --newversion $GIT_VERSION-$DATE "Auto-Build"
+fi
 
 # Using pbuilder and pdebuild in chroot instead of building directly : dpkg-buildpackage -b -rfakeroot -uc -us