add option to limit automatic unsuspensions to a specific suspension reason type...
[freeside.git] / bin / freeside-debian-releases.sh
index ed4c005..4e42c23 100755 (executable)
@@ -10,8 +10,8 @@ if [[ $# -ne 3 ]]
     exit;
 fi
 
-DATE=`date +"%Y%m%d"`
-DIR="/home/autobuild/packages/staging/freeside$FS_VERSION/$FS_REPO"
+DATE=`date +"%Y%m%d%H"`
+DIR="/home/autobuild/packages/staging/freeside$FS_VERSION/$DISTRO/$FS_REPO"
 TARGET="/home/autobuild/public_html/freeside$FS_VERSION-$DISTRO-$FS_REPO"
 
 if [ ! -d "$DIR" -a -d $TARGET ]; then
@@ -22,12 +22,19 @@ fi
 
 GIT_VERSION=`grep '^$VERSION' $DIR/freeside/FS/FS.pm | cut -d\' -f2`
 
-# Clean configuration file
-rm -fr $DIR/freeside/debian/freeside-ng-selfservice.conffiles
-
 # Pull any changes
 cd $DIR/freeside
 git checkout -- debian/changelog
+
+LOCAL=`git rev-parse FREESIDE_${FS_VERSION}_BRANCH`
+REMOTE=`git ls-remote origin -h refs/heads/FREESIDE_${FS_VERSION}_BRANCH | cut -f1`
+
+if [ $LOCAL = $REMOTE ]; then
+  echo "No new changes in git; aborting build."
+  exit #there's no new changes
+fi
+echo "New changes in git since last build; building new packages."
+
 git pull
 #STATUS=`git pull`
 
@@ -45,8 +52,11 @@ pdebuild --pbuilderroot sudo --debbuildopts "-b -rfakeroot -uc -us" --buildresul
 cd $DIR && rm -f freeside_*
 cd $TARGET && rm -f *.gz
 
-apt-ftparchive -qq packages ./ | gzip >Packages.gz
-apt-ftparchive -qq sources ./ | gzip >Sources.gz
-apt-ftparchive -qq packages ./ | bzip2 >Packages.bz2
-apt-ftparchive -qq sources ./ | bzip2 >Sources.bz2
+apt-ftparchive -qq packages ./ >Packages
+gzip -c Packages >Packages.gz
+#bzip2 -c Packages >Packagez.bz2
+apt-ftparchive -qq sources ./ >Sources
+gzip -c Sources >Sources.gz
+#bzip2 -c Sources >Sources.bz2
+rm *bz2 || true
 apt-ftparchive -qq release ./ >Release