summaryrefslogtreecommitdiff
path: root/install/5.005/Net-Whois-Raw/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'install/5.005/Net-Whois-Raw/Makefile.PL')
-rwxr-xr-xinstall/5.005/Net-Whois-Raw/Makefile.PL24
1 files changed, 24 insertions, 0 deletions
diff --git a/install/5.005/Net-Whois-Raw/Makefile.PL b/install/5.005/Net-Whois-Raw/Makefile.PL
new file mode 100755
index 0000000..abd0ca3
--- /dev/null
+++ b/install/5.005/Net-Whois-Raw/Makefile.PL
@@ -0,0 +1,24 @@
+#!/usr/bin/perl -w
+
+use ExtUtils::MakeMaker;
+# See lib/ExtUtils/MakeMaker.pm for details of how to influence
+# the contents of the Makefile that is written.
+
+sub MY::postamble {
+ package MY;
+ shift->SUPER::postamble . <<'MAKE';
+dist : README
+
+README : lib/Net/Whois/Raw.pm
+ @$(PERL) -MPod::Text -e "pod2text('$<');" > $@
+
+MAKE
+}
+
+WriteMakefile(
+ 'NAME' => 'Net::Whois::Raw',
+ 'VERSION_FROM' => 'lib/Net/Whois/Raw.pm', # finds $VERSION
+ 'PREREQ_PM' => {'IO::Socket' => 1.0},
+ 'EXE_FILES' => ['pwhois'],
+ 'dist' => {'COMPRESS' => 'gzip --best --force'},
+);