summaryrefslogtreecommitdiff
path: root/rt/configure.ac
diff options
context:
space:
mode:
authorivan <ivan>2007-08-02 19:56:20 +0000
committerivan <ivan>2007-08-02 19:56:20 +0000
commitef20b2b6b1feb47ad02b5ff7525f1a0fd11d0fa4 (patch)
treea2ea500cf510739908761a6bfbd14e990131f2cc /rt/configure.ac
parenta513c0bef534d05f03c1242831b6f3be19b97dae (diff)
import rt 3.6.4
Diffstat (limited to 'rt/configure.ac')
-rw-r--r--rt/configure.ac15
1 files changed, 13 insertions, 2 deletions
diff --git a/rt/configure.ac b/rt/configure.ac
index 0d38ba4..4510e84 100644
--- a/rt/configure.ac
+++ b/rt/configure.ac
@@ -3,11 +3,11 @@ dnl
dnl Process this file with autoconf to produce a configure script
dnl
dnl Embed in generated ./configure script the following CVS info:
-AC_REVISION($Revision: 1.1.1.6 $)dnl
+AC_REVISION($Revision: 1.1.1.7 $)dnl
dnl Setup autoconf
AC_PREREQ(2.53)
-AC_INIT(RT, [3.4.5], [rt-bugs@fsck.com])
+AC_INIT(RT, [3.6.4], [rt-bugs@bestpractical.com])
AC_CONFIG_SRCDIR([lib/RT.pm.in])
dnl Extract RT version number components
@@ -202,6 +202,8 @@ AC_ARG_WITH(rt-group,
AC_SUBST(RTGROUP)
dnl INSTALL AS ME
+# XXX TODO: The command below to figure out the group brokenly relies on
+# output order (and "id -gn" doesn't work on all platforms).
my_group=$(groups|cut -f1 -d' ')
my_user=${USER:-$LOGNAME}
AC_ARG_WITH(my-user-group,
@@ -234,6 +236,15 @@ AC_ARG_WITH(apachectl,
APACHECTL=`which apachectl`)
AC_SUBST(APACHECTL)
+dnl RT's standalone pure perl server
+AC_ARG_WITH(devel-mode,
+ AC_HELP_STRING([--with-standalone],
+ [Install modules for pure perl standalone server]),
+
+ RT_STANDALONE="1",
+ RT_STANDALONE="0")
+AC_SUBST(RT_STANDALONE)
+
dnl RT's "maintainer mode"
AC_ARG_WITH(devel-mode,
AC_HELP_STRING([--with-devel-mode],