summaryrefslogtreecommitdiff
path: root/rt/configure.ac
diff options
context:
space:
mode:
authorivan <ivan>2008-03-02 04:11:51 +0000
committerivan <ivan>2008-03-02 04:11:51 +0000
commit8103c1fc1b2c27a6855feadf26f91b980a54bc52 (patch)
tree631dd45606c37c00d9026e14ecc3ee3700b4b51c /rt/configure.ac
parent9c68254528b6f2c7d8c1921b452fa56064783782 (diff)
import rt 3.6.6
Diffstat (limited to 'rt/configure.ac')
-rw-r--r--rt/configure.ac15
1 files changed, 13 insertions, 2 deletions
diff --git a/rt/configure.ac b/rt/configure.ac
index 1866a1d..2a3271d 100644
--- a/rt/configure.ac
+++ b/rt/configure.ac
@@ -3,11 +3,11 @@ dnl
dnl Process this file with autoconf to produce a configure script
dnl
dnl Embed in generated ./configure script the following CVS info:
-AC_REVISION($Revision: 1.1.1.8 $)dnl
+AC_REVISION($Revision: 1.1.1.9 $)dnl
dnl Setup autoconf
AC_PREREQ(2.53)
-AC_INIT(RT, [3.4.6], [rt-bugs@fsck.com])
+AC_INIT(RT, [3.6.6], [rt-bugs@bestpractical.com])
AC_CONFIG_SRCDIR([lib/RT.pm.in])
dnl Extract RT version number components
@@ -202,6 +202,8 @@ AC_ARG_WITH(rt-group,
AC_SUBST(RTGROUP)
dnl INSTALL AS ME
+# XXX TODO: The command below to figure out the group brokenly relies on
+# output order (and "id -gn" doesn't work on all platforms).
my_group=$(groups|cut -f1 -d' ')
my_user=${USER:-$LOGNAME}
AC_ARG_WITH(my-user-group,
@@ -234,6 +236,15 @@ AC_ARG_WITH(apachectl,
APACHECTL=`which apachectl`)
AC_SUBST(APACHECTL)
+dnl RT's standalone pure perl server
+AC_ARG_WITH(devel-mode,
+ AC_HELP_STRING([--with-standalone],
+ [Install modules for pure perl standalone server]),
+
+ RT_STANDALONE="1",
+ RT_STANDALONE="0")
+AC_SUBST(RT_STANDALONE)
+
dnl RT's "maintainer mode"
AC_ARG_WITH(devel-mode,
AC_HELP_STRING([--with-devel-mode],