summaryrefslogtreecommitdiff
path: root/rt/configure.ac
diff options
context:
space:
mode:
authorIvan Kohler <ivan@freeside.biz>2016-09-24 10:28:06 -0700
committerIvan Kohler <ivan@freeside.biz>2016-09-24 10:28:06 -0700
commit7322f2afedcc2f427e997d1535a503613a83f088 (patch)
tree6c0d4e68906bfdaaff2a2067620e222611b979ea /rt/configure.ac
parentae14e320388fa5e7f400bff1c251ef885b7952e6 (diff)
rt 4.2.13 ticket#13852
Diffstat (limited to 'rt/configure.ac')
-rw-r--r--rt/configure.ac14
1 files changed, 13 insertions, 1 deletions
diff --git a/rt/configure.ac b/rt/configure.ac
index 8fd2e58..4c7995a 100644
--- a/rt/configure.ac
+++ b/rt/configure.ac
@@ -34,6 +34,16 @@ if test "$PERL" = 'not found'; then
AC_MSG_ERROR([cannot use $PACKAGE_NAME without perl])
fi
+dnl BSD find uses -perm +xxxx, GNU find has deprecated this syntax in favour of
+dnl -perm /xxx.
+AC_MSG_CHECKING([checking version of find])
+AS_IF([find --version 2>&1 | grep 'GNU'],
+ [ FINDPERM="/"
+ AC_MSG_RESULT([configuring for GNU find]) ],
+ [ FINDPERM="+"
+ AC_MSG_RESULT([configuring for BSD find]) ])
+
+AC_SUBST([FINDPERM])
dnl WEB_HANDLER
AC_ARG_WITH(web-handler,
@@ -461,6 +471,8 @@ AC_CONFIG_FILES([
etc/RT_Config.pm
lib/RT/Generated.pm
t/data/configs/apache2.2+mod_perl.conf
- t/data/configs/apache2.2+fastcgi.conf],
+ t/data/configs/apache2.2+fastcgi.conf
+ t/data/configs/apache2.4+mod_perl.conf
+ t/data/configs/apache2.4+fastcgi.conf],
)
AC_OUTPUT