summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJeremy Davis <jeremyd@freeside.biz>2015-06-25 11:55:18 -0400
committerJeremy Davis <jeremyd@freeside.biz>2015-06-25 11:55:18 -0400
commit34decf4ce97085061e866a4b22d9e9caef2bf5b6 (patch)
treef6cfcedfad9865ee912f48bc10d0516e0dfa3f6e /debian
parent4236fc4ad0d80b80bbdf1e013976f0bbe85fcf16 (diff)
Ticket #36913 Fix Apache config
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules5
1 files changed, 3 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 3181fe882..f39007240 100755
--- a/debian/rules
+++ b/debian/rules
@@ -53,6 +53,7 @@ export INIT_FILE = $(TMP).init
export INIT_INSTALL = /bin/true
export HTTPD_RESTART = /bin/true
export APACHE_CONF := $(shell [ ${APACHE_VERSION} = '2.4' ] && echo "$(TMP)-webui/etc/apache2/conf-available" || echo "$(TMP)-webui/etc/apache2/conf.d")
+export TORRUS_CONF := $(shell [ ${APACHE_VERSION} = '2.4' ] && echo "$(TMP)-torrus/etc/apache2/conf-available" || echo "$(TMP)-torrus/etc/apache2/conf.d")
export FREESIDE_RESTART = /bin/true
#XXX root?
@@ -227,8 +228,8 @@ install-stamp: build-stamp
# Torrus
- install -d ${TMP}-torrus${APACHE_CONF}
- install -o root -m 755 htetc/freeside-torrus.conf ${TMP}-torrus$(APACHE_CONF)/
+ install -d ${TORRUS_CONF}
+ install -o root -m 755 htetc/freeside-torrus.conf $(TORRUS_CONF)/
( cd torrus; \
torrus_user=freeside var_user=freeside var_group=freeside ./configure; \