summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorIvan Kohler <ivan@freeside.biz>2016-01-29 01:33:08 -0800
committerIvan Kohler <ivan@freeside.biz>2016-01-29 01:33:08 -0800
commitdb676d7c8aaa25f5d749c28b8f6bc1908a37c144 (patch)
treef7d46a28ab403b82cf3e43db5eb753e43ef25a83 /debian/rules
parent641170eeaa9405d9b8c66f586a039a49246db92b (diff)
more accurate split of files into -webui and -lib packages
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules8
1 files changed, 4 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index 38b6b0a..4a2bf6e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -76,7 +76,7 @@ export FREESIDE_URL = http://$(HOSTNAME)/freeside/
# a kludge to hack it out afterwords. look into using fakeroot (didn't
# realize it would need to be explicit argh)
# (but leaving it for now, otherwise can't get RT to put files where we need em)
-export RT_PATH = $(TMP)/opt/rt3
+export RT_PATH = $(TMP)-lib/opt/rt3
export TEXMF_PATH = $(TMP)-lib/usr/local/share/texmf/tex/latex
@@ -134,7 +134,7 @@ install-stamp: build-stamp
install -d $(TMP)-webui/usr/local/etc/freeside/
install -d $(TMP)-webui/etc/insserv/overrides/
install -d $(TMP)/usr/local/etc/freeside/
- install -d $(FREESIDE_CACHE)/masondata #MASONDATA
+ install -d $(TMP)-webui/masondata #MASONDATA
# install -d $(TMP)-lib/usr/bin
( cd FS/ && $(MAKE) -e DESTDIR=${TMP}-lib install)
@@ -271,7 +271,7 @@ install-stamp: build-stamp
##hack the build dir out of RT. yeah, sucky.
perl -p -i -e "\
- s'${TMP}(-webui)''g;\
+ s'${TMP}(-webui|-lib)''g;\
s'${TMP}''g;\
" ${TMP}/opt/rt3/etc/*.pm \
${TMP}/opt/rt3/lib/*.pm \
@@ -299,7 +299,7 @@ binary-indep: build install
dh_testroot
dh_installdeb install
dh_installdocs #freeside.docs README AGPL
- dh_installexamples eg/*
+ dh_installexamples eg/* bin
# dh_installmenu
dh_installdebconf
# dh_installlogrotate