Browser support

From Freeside
Jump to: navigation, search

Maintenance (3.x) (as of 10/2016)

  • IE 8+ (lots of WinXP clients out there still)
  • Firefox 45+ ("Extended Support Release")
  • Chrome 37+ (version of chromium in Debian 7)
  • Safari 5+
  • Opera (12+?)

Current (4.x)

  • IE11+ (Win7)
    • folks still on XP after its EOL can use Firefox, IE 11 is now available on Win 7 (and after January 2016, the only supported browser)
    • chrome on xp support ends April 2016 ended with Chrome 50.
    • Firefox 52 is the last version that runs on XP. It is supported as ESR until March 2018. After that, we're not testing/supporting anything on XP anymore
    • windows security essentials stopped being supported on XP in july 2015
    • malicious software removal tool was supposed to end then too, but it has continued to show up until 5/2016 so far
    • MS dropped support for older browsers on a platform as of January 2016
  • Edge (Win10)
  • Firefox 52+ (current/latest ESR)
  • Chrome 54+
  • Safari 9+? (latest running on the still-used OSX/iOS versions)
  • Opera latest (still supported, but v15+ uses the same engine as Chrome, so not separately tested)

Future (5.x)

  • IE11+ (Win 8.1)
  • Edge (Win10)
  • Firefox (current/latest ESR)
  • Chrome (current)
  • Safari (current)
Personal tools
Namespaces

Variants
Actions
Navigation
Tools