import rt 3.2.2
[freeside.git] / rt / configure.ac
index 04f3d83..85f1b00 100644 (file)
@@ -1,12 +1,13 @@
+autoconf; exec ./configure $@
 dnl
 dnl Process this file with autoconf to produce a configure script
 dnl
 dnl Embed in generated ./configure script the following CVS info:
-AC_REVISION($Revision: 1.1.1.3 $)dnl
+AC_REVISION($Revision: 1.1.1.4 $)dnl
 
 dnl Setup autoconf
 AC_PREREQ(2.53)
-AC_INIT(RT, [3.0.12], [rt-3.0-bugs@fsck.com])
+AC_INIT(RT, [3.2.2], [rt-bugs@fsck.com])
 AC_CONFIG_SRCDIR([lib/RT.pm.in])
 
 dnl Extract RT version number components
@@ -27,6 +28,8 @@ AC_PATH_PROG([PERL], [perl], [not found])
 if test "$PERL" = 'not found'; then
        AC_MSG_ERROR([cannot use $PACKAGE_NAME without perl])
 fi
+
+
 dnl SPEED_BIN
 AC_ARG_WITH(speedycgi,
            AC_HELP_STRING([--with-speedycgi=/path/to/speedy],
@@ -51,7 +54,7 @@ AC_SUBST(RTGROUP)
 dnl BIN_OWNER
 AC_ARG_WITH(bin-owner,
            AC_HELP_STRING([--with-bin-owner=OWNER],
-                          [user that will own rt binaries (default root)]),
+                          [user that will own RT binaries (default root)]),
             BIN_OWNER=$withval,
             BIN_OWNER=root)
 AC_SUBST(BIN_OWNER)
@@ -67,7 +70,7 @@ AC_SUBST(LIBS_OWNER)
 dnl LIBS_GROUP
 AC_ARG_WITH(libs-group,
            AC_HELP_STRING([--with-libs-group=GROUP],
-                          [group that will own rt binaries (default bin)]),
+                          [group that will own RT binaries (default bin)]),
             LIBS_GROUP=$withval,
             LIBS_GROUP=bin)
 AC_SUBST(LIBS_GROUP)
@@ -75,20 +78,26 @@ AC_SUBST(LIBS_GROUP)
 dnl DB_TYPE
 AC_ARG_WITH(db-type,
            AC_HELP_STRING([--with-db-type=TYPE],
-                          [sort of database RT will use (default: mysql) (mysql, Pg, Oracle and Informix are valid)]), 
+                          [sort of database RT will use (default: mysql) (mysql, Pg, Oracle, Informix and SQLite are valid)]), 
             DB_TYPE=$withval,
             DB_TYPE=mysql)
-if test "$DB_TYPE" != 'mysql' -a "$DB_TYPE" != 'Pg' -a "$DB_TYPE" != 'SQLite' -a "$DB_TYPE" != 'Oracle' -a "$DB_TYPE" != 'Informix' ; then
-       AC_MSG_ERROR([Only Oracle, Informix, Pg and mysql are valid db types])
+if test "$DB_TYPE" != 'mysql' -a "$DB_TYPE" != 'Pg' -a "$DB_TYPE" != 'SQLite' -a "$DB_TYPE" != 'Oracle' -a "$DB_TYPE" != 'Informix' -a "$DB_TYPE" != 'Sybase' ; then
+       AC_MSG_ERROR([Only Oracle, Informix, Pg, mysql and SQLite are valid db types])
 fi
 AC_SUBST(DB_TYPE)
 
-dnl ORACLE_ENV_PREF
+dnl DATABASE_ENV_PREF
 if test "$DB_TYPE" = 'Oracle'; then
        test "x$ORACLE_HOME" = 'x' && AC_MSG_ERROR([Please declare the ORACLE_HOME environment variable])
-       ORACLE_ENV_PREF="\$ENV{'ORACLE_HOME'} = '$ORACLE_HOME';"
+       DATABASE_ENV_PREF="\$ENV{'ORACLE_HOME'} = '$ORACLE_HOME';"
+fi
+
+dnl DATABASE_ENV_PREF
+if test "$DB_TYPE" = 'Sybase'; then
+       test "x$SYBASE" = 'x' && AC_MSG_ERROR([Please declare the SYBASE_HOME environment variable])
+       DATABASE_ENV_PREF="\$ENV{'SYBASE'} = '$SYBASE';"
 fi
-AC_SUBST(ORACLE_ENV_PREF)
+AC_SUBST(DATABASE_ENV_PREF)
 
 dnl DB_HOST
 AC_ARG_WITH(db-host,
@@ -174,6 +183,17 @@ AC_ARG_WITH(my-user-group,
             WEB_USER=$USER
             WEB_GROUP=$my_group)
 
+
+
+dnl Set the value of apachectl
+AC_ARG_WITH(apachectl,
+            AC_HELP_STRING([--with-apachectl],
+                           [instruct RT where to find your apachectl]),
+
+            APACHECTL=$withval, 
+            APACHECTL=`which apachectl`)
+AC_SUBST(APACHECTL)
+
 dnl This section maps the variable names this script 'natively' generates
 dnl to their existing names. They should be removed from here as the .in
 dnl files are changed to use the new names.
@@ -217,10 +237,11 @@ AC_CONFIG_FILES([
                  lib/t/02regression.t
                  lib/t/03web.pl
                  lib/t/04_send_email.pl
+                lib/t/05cronsupport.pl
                 bin/mason_handler.fcgi
                 bin/mason_handler.scgi
+                bin/standalone_httpd
                 bin/mason_handler.svc
-                bin/rt-commit-handler
                 bin/rt-crontool
                 bin/rt-mailgate
                 bin/rt