torrus
[freeside.git] / debian / rules
index 38b6b0a..041c895 100755 (executable)
@@ -76,7 +76,7 @@ export FREESIDE_URL           = http://$(HOSTNAME)/freeside/
 # a kludge to hack it out afterwords.  look into using fakeroot (didn't
 # realize it would need to be explicit argh)
 # (but leaving it for now, otherwise can't get RT to put files where we need em)
-export RT_PATH                = $(TMP)/opt/rt3
+export RT_PATH                = $(TMP)-lib/opt/rt3
 
 export TEXMF_PATH             = $(TMP)-lib/usr/local/share/texmf/tex/latex
 
@@ -134,7 +134,6 @@ install-stamp: build-stamp
        install -d $(TMP)-webui/usr/local/etc/freeside/
        install -d $(TMP)-webui/etc/insserv/overrides/
        install -d $(TMP)/usr/local/etc/freeside/
-       install -d $(FREESIDE_CACHE)/masondata #MASONDATA
 #      install -d $(TMP)-lib/usr/bin
 
        ( cd FS/ && $(MAKE) -e DESTDIR=${TMP}-lib install)
@@ -229,8 +228,9 @@ install-stamp: build-stamp
 
        # Torrus 
        
-       install -d ${TORRUS_CONF}
-       install -o root -m 755 htetc/freeside-torrus.conf $(TORRUS_CONF)/
+       #in freeside-webui package
+       #install -d ${TORRUS_CONF}
+       #install -o root -m 755 htetc/freeside-torrus.conf $(TORRUS_CONF)/
 
        ( cd torrus; \
        torrus_user=freeside var_user=freeside var_group=freeside ./configure; \
@@ -266,19 +266,19 @@ install-stamp: build-stamp
        install -d $(RT_PATH)/share
 
        ( cd rt; $(MAKE) config-install dirs files-install fixperms instruct )
-       cp -r ${RT_PATH}/share/static/images ${FREESIDE_DOCUMENT_ROOT}/rt/NoAuth/
+       cp -r rt/share/static/images ${FREESIDE_DOCUMENT_ROOT}/rt/NoAuth/
        
        ##hack the build dir out of RT.  yeah, sucky.
 
        perl -p -i -e "\
-       s'${TMP}(-webui)''g;\
+       s'${TMP}(-webui|-lib)''g;\
        s'${TMP}''g;\
-       " ${TMP}/opt/rt3/etc/*.pm \
-               ${TMP}/opt/rt3/lib/*.pm \
-               ${TMP}/opt/rt3/lib/RT/*.pm \
-               ${TMP}/opt/rt3/etc/upgrade/* \
-               ${TMP}/opt/rt3/sbin/* \
-               ${TMP}/opt/rt3/bin/* \
+       " ${TMP}-lib/opt/rt3/etc/*.pm \
+               ${TMP}-lib/opt/rt3/lib/*.pm \
+               ${TMP}-lib/opt/rt3/lib/RT/*.pm \
+               ${TMP}-lib/opt/rt3/etc/upgrade/* \
+               ${TMP}-lib/opt/rt3/sbin/* \
+               ${TMP}-lib/opt/rt3/bin/* \
 
        # Default RT Settings
        perl -p -i -e "\
@@ -299,7 +299,7 @@ binary-indep: build install
        dh_testroot
        dh_installdeb install
        dh_installdocs #freeside.docs README AGPL
-       dh_installexamples eg/*
+       dh_installexamples eg bin
 #      dh_installmenu
        dh_installdebconf       
 #      dh_installlogrotate