This commit was generated by cvs2svn to compensate for changes in r2523,
[freeside.git] / rt / etc / rt.spec
1 Summary: rt Request Tracker
2
3 Name: rt
4 Version: 2.0.9pre5
5 Release: 1
6 Group: Applications/Web
7 Packager: Jesse Vincent <jesse@bestpractical.com>
8 Vendor: http://www.fsck.com/projects/rt
9 Requires: perl
10 Requires: mod_perl > 1.22
11 Requires: perl-DBI >= 1.18
12 Requires: perl-DBIx-DataSource >= 0.02
13 Requires: perl-DBIx-SearchBuilder >= 0.47
14 Requires: perl-HTML-Parser
15 Requires: perl-MLDBM
16 Requires: perl-libnet
17 Requires: perl-CGI.pm >= 2.78
18 Requires: perl-Params-Validate >= 0.02
19 Requires: perl-HTML-Mason >= 0.896
20 Requires: perl-libapreq
21 Requires: perl-Apache-Session >= 1.53
22 Requires: perl-MIME-tools >= 5.411
23 Requires: perl-MailTools >= 1.20
24 Requires: perl-Getopt-Long >= 2.24
25 Requires: perl-Tie-IxHash
26 Requires: perl-TimeDate
27 Requires: perl-Time-HiRes
28 Requires: perl-Text-Wrapper
29 Requires: perl-Text-Template
30 Requires: perl-File-Spec >= 0.8
31 Requires: perl-FreezeThaw
32 Requires: perl-Storable
33 Requires: perl-File-Temp
34 Requires: perl-Log-Dispatch >= 1.6                     
35
36 Source: http://www.fsck.com/pub/rt/release/%{name}.tar.gz
37  
38 Copyright: GPL 
39 BuildRoot: /var/tmp/rt-root
40
41 %description
42 RT is an industrial-grade ticketing system. It lets a group
43 of people intelligently and efficiently manage requests
44 submitted by a community of users. RT is used by systems
45 administrators, customer support staffs, NOCs, developers
46 and even marketing departments at over a thousand sites
47 around the world. 
48
49 %prep
50 groupadd rt || true
51 %setup -q -n %{name}
52
53 %build
54
55 %install
56
57 if [ x$RPM_BUILD_ROOT != x ]; then
58 rm -rf $RPM_BUILD_ROOT
59 fi
60
61 #
62 # Perform all the non-site specfic steps whilst building the package
63 #
64 make dirs libs-install html-install bin-install  DESTDIR=$RPM_BUILD_ROOT
65 #
66 # fixperms needs these, so make fake empty files
67 touch $RPM_BUILD_ROOT/opt/rt2/etc/insertdata $RPM_BUILD_ROOT/opt/rt2/etc/config.pm
68 make fixperms insert-install WEB_USER=www DESTDIR=$RPM_BUILD_ROOT
69
70 #
71 # Copy in the files needed again after install
72 #
73 mkdir -p $RPM_BUILD_ROOT/opt/rt2/postinstall/bin
74 cp -rp Makefile etc tools $RPM_BUILD_ROOT/opt/rt2/postinstall
75 cp -rp bin/initacls.* $RPM_BUILD_ROOT/opt/rt2/postinstall/bin
76
77 # logging in /var/log/rt2
78 mkdir -p $RPM_BUILD_ROOT/var/log/rt2
79 chown www $RPM_BUILD_ROOT/var/log/rt2
80 chgrp rt $RPM_BUILD_ROOT/var/log/rt2
81 chmod ug=rwx,o= $RPM_BUILD_ROOT/var/log/rt2
82
83 %clean
84 if [ x$RPM_BUILD_ROOT != x ]; then
85 rm -rf $RPM_BUILD_ROOT
86 fi
87
88 #
89 # A new rt groups is required
90 #
91 %pre
92 groupadd rt || true
93
94 #
95 # Show the user the site specific steps required after install
96 #
97 %post
98 cat <<EOF
99 -----------------------------------------------------------------------
100 rt2 installation is complete. Now create the rt2 database by running:
101 -----------------------------------------------------------------------
102
103 # cd /opt/rt2/postinstall
104 # make config-replace initialize.mysql insert RT_LOG_PATH=/var/log/rt2 DB_RT_PASS=new_rt_user_password
105
106 Choose your own new_rt_user_password. You will need the mysql root password.
107 You can try Pg or Oracle instead of mysql - untested.
108
109 Review and configure your site specific details in /opt/rt2/etc/config.pm
110 EOF
111
112 %preun
113
114 %files
115 %dir /opt/rt2
116 /opt/rt2/bin
117 /opt/rt2/WebRT
118 /opt/rt2/lib
119 /opt/rt2/local
120 /opt/rt2/man
121 /opt/rt2/postinstall
122 %dir /opt/rt2/etc
123 /opt/rt2/etc/insertdata
124 %config /opt/rt2/etc/config.pm
125 %dir /var/log/rt2
126
127 %changelog
128 * Mon Sep 24 2001 Jesse Vincent <jesse@bestpractical.com>
129   Switch to rt DESTDIR support
130 * Fri Sep 14 2001 Cris Bailiff <c.bailiff@devsecure.com>
131   Fix permissions on created /var/log/rt2 and roll in 2.0.7
132 * Tue Sep 4 2001 Cris Bailiff <c.bailiff@devsecure.com>
133 - created initial spec file
134 * Tue Sep 4 2001 Cris Bailiff <c.bailiff@devsecure.com>
135 - created initial spec file
136 * Tue Sep 4 2001 Cris Bailiff <c.bailiff@devsecure.com>
137 - created initial spec file