summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJeremy Davis <jeremyd@freeside.biz>2014-11-18 14:14:14 -0500
committerJeremy Davis <jeremyd@freeside.biz>2014-11-18 14:14:14 -0500
commitf27fc0c47675bb7b3aab58153caf51a435c7a610 (patch)
treec4901ae807c55e4cfdd8c43a6a31990cb2e55a58 /debian
parent0c9ebb4513cc31abb424d56cd9e6290da1814167 (diff)
Ticket 2916 Debian packages
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules4
1 files changed, 2 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index e69d411d2..c658278d9 100755
--- a/debian/rules
+++ b/debian/rules
@@ -93,7 +93,7 @@ build-stamp:
dh_testdir
# Add commands to compile the package here
- ( cd FS/ && $(PERL) Makefile.PL INSTALLDIRS=vendor && [ -e Makefile ] || perl Makefile.PL && make )
+ ( cd FS/ && $(PERL) Makefile.PL PREFIX=$(TMP)-lib/usr INSTALLDIRS=vendor && [ -e Makefile ] || perl Makefile.PL && make )
#install this for freeside-setup
install -d $(DIST_CONF)
@@ -130,7 +130,7 @@ install-stamp: build-stamp
install -d $(TMP)/usr/local/etc/freeside/
install -d $(FREESIDE_CACHE)/masondata #MASONDATA
- ( cd FS/ && $(MAKE) -e DESTDIR=${TMP}-lib install UNINST=1 )
+ ( cd FS/ && $(MAKE) -e DESTDIR=${TMP}-lib install)
# Install configuration files
install -d -o freeside ${FREESIDE_CONF}