summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJeremy Davis <jeremyd@freeside.biz>2014-11-19 16:06:26 -0500
committerJeremy Davis <jeremyd@freeside.biz>2014-11-19 16:06:26 -0500
commitf21bc7ca7e1c94b073004569a8506811898e15c4 (patch)
treead1fa202fb69cf169f49d196e079d11c3e16706e /debian
parent933897259d1e64fdc12c612f924db3b039a9ffdf (diff)
Ticket #2916 Debian packages
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules7
1 files changed, 4 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index be2a5a296..0d90a7fca 100755
--- a/debian/rules
+++ b/debian/rules
@@ -93,8 +93,8 @@ build-stamp:
dh_testdir
# Add commands to compile the package here
- ( cd FS/ && $(PERL) Makefile.PL INSTALLDIRS=vendor && [ -e Makefile ] || perl Makefile.PL && make )
-
+ ( cd FS/ && $(PERL) Makefile.PL INSTALLDIRS=vendor && $(MAKE) )
+ $(MAKE) perl-modules
#install this for freeside-setup
install -d $(DIST_CONF)
install `ls -d conf/[a-z]* | grep -v CVS | grep -v '^conf/registries'` $(DIST_CONF)
@@ -128,8 +128,9 @@ install-stamp: build-stamp
install -d $(TMP)-webui/usr/local/etc/freeside/
install -d $(TMP)/usr/local/etc/freeside/
install -d $(FREESIDE_CACHE)/masondata #MASONDATA
+# install -d $(TMP)-lib/usr/bin
- ( cd FS/ && $(MAKE) -e DESTDIR=${TMP} install)
+ ( cd FS/ && $(MAKE) -e DESTDIR=${TMP}-lib install)
# Install configuration files
install -d -o freeside ${FREESIDE_CONF}