summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorivan <ivan>2008-05-13 03:49:03 +0000
committerivan <ivan>2008-05-13 03:49:03 +0000
commit6726ccd411b87ab1c92942201ebd0677f79dd59d (patch)
treee31e3cfebab03e3e00bee8d8442509163fa999d4 /debian/rules
parenteaafe49123e402598d1e350c5654b7870073740d (diff)
better place for initial configuration to be stored and retreived from than the initial tarball...
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 4 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 2d9b643a8..1e5b9f0ec 100755
--- a/debian/rules
+++ b/debian/rules
@@ -57,7 +57,7 @@ export FREESIDE_URL = http://$(HOSTNAME)/freeside/
#specific to deb pkg, for purposes of saving off a permanent copy of default
#config for postinst and that sort of thing
-export DEFAULT_CONF = $(TMP)/usr/share/freeside/default_conf
+export DIST_CONF = $(TMP)/usr/share/freeside/default_conf
#XXX yuck. proper RT layout is entirely necessary
#this seems to infect way to much of RT with the build location, requiring
@@ -112,11 +112,12 @@ install-stamp: build-stamp
# debian/<package>-whatever.
( cd FS/ && $(MAKE) -e DESTDIR=$(TMP)-lib install )
+ #falase laziness w/install-perl-modules now
#install this for postinst later (no create-config)
- install -d $(DEFAULT_CONF)
+ install -d $(DIST_CONF)
#install conf/[a-z]* $(DEFAULT_CONF)
#CVS is not [a-z]
- install `ls -d conf/[a-z]* | grep -v CVS` $(DEFAULT_CONF)
+ install `ls -d conf/[a-z]* | grep -v CVS` $(DIST_CONF)
install -d $(FREESIDE_DOCUMENT_ROOT)
install -d $(FREESIDE_CACHE)/masondata #MASONDATA