summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMark Wells <mark@freeside.biz>2015-07-02 17:27:18 -0700
committerMark Wells <mark@freeside.biz>2015-07-02 19:52:07 -0700
commit43ec777308c7717e2f4fb75ac96a710baa4b87ba (patch)
treeb9c2a580d4fb13823750b1a2f4e3f189f5d4313b /debian/rules
parentf458c57d91c7111c27fe84f5ef50336e7e82e23e (diff)
add tex style to debian/rules
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 4 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index f39007240..a7f2b72d0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -78,6 +78,8 @@ export FREESIDE_URL = http://$(HOSTNAME)/freeside/
# (but leaving it for now, otherwise can't get RT to put files where we need em)
export RT_PATH = $(TMP)/opt/rt3
+export TEXMF_PATH = $(TMP)-lib/usr/local/share/texmf/tex/latex
+
# This has to be exported to make some magic below work.
export DH_OPTIONS
@@ -167,9 +169,8 @@ install-stamp: build-stamp
$(MAKE) -e DESTDIR=$(TMP)-webui install-docs
# Install tex
- install -D -o freeside -m 444 etc/longtable.sty \
- $(TMP)-lib/usr/local/share/texmf/tex/latex/longtable.sty
- texhash $(TMP)-lib/usr/local/share/texmf
+ install -d ${TEXMF_PATH}
+ install -o freeside -m 444 etc/*.sty ${TEXMF_PATH}
# Create Apache configurations
install -d $(APACHE_CONF)