summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJeremy Davis <jeremyd@freeside.biz>2014-11-07 16:03:24 -0500
committerJeremy Davis <jeremyd@freeside.biz>2014-11-07 16:03:24 -0500
commit19f1e7a1b3aafc2d7181d8cb286f702707ca654b (patch)
tree9ff7a48fa4faa0cda9248fe193a20b3e1192b89f /debian/rules
parentd7ae630be5b8ee3aa3b8d15b26ea29876fcd43cb (diff)
Ticket #31999 Fix issues with ordering of debian package builds
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules17
1 files changed, 9 insertions, 8 deletions
diff --git a/debian/rules b/debian/rules
index 38fdcc7f7..be6ce5111 100755
--- a/debian/rules
+++ b/debian/rules
@@ -122,12 +122,14 @@ install-stamp: build-stamp
install -d $(FREESIDE_DOCUMENT_ROOT)
install -d $(TMP)-webui/usr/local/etc/freeside/
+ install -d $(TMP)/usr/local/etc/freeside/
install -d $(FREESIDE_CACHE)/masondata #MASONDATA
- $(MAKE) -e DESTDIR=$(TMP)-webui install-docs
+ # Install configuration files, hack what to do???
+ $(MAKE) -e DESTDIR=$(TMP) create-config
- # Ugly hack, why is handler.pl not being "handled" by install-docs
- install -D htetc/handler.pl DESTDIR=$(FREESIDE_CACHE)
+ # Install interfaces
+ $(MAKE) -e DESTDIR=$(TMP)-webui install-docs
# Create Apache configurations
install -d $(APACHE_CONF)
@@ -139,23 +141,22 @@ install-stamp: build-stamp
s'${TMP}(-webui)?''g;\
" $(TMP)-webui/etc/freeside/apache2/*
- # Install configuration files, hack what to do???
- $(MAKE) -e DESTDIR=$(TMP) create-config
+ # Install init
$(MAKE) -e DESTDIR=$(TMP) install-init
#hack the build dir out of Freeside too. oh yeah, sucky.
perl -p -i -e "\
s'${TMP}(-webui)?''g;\
- " ${TMP}-webui/usr/share/freeside/handler.pl \
+ " ${TMP}/usr/local/etc/freeside/handler.pl \
${TMP}/usr/share/perl5/FS/* \
${TMP}/usr/share/perl5/FS/*/* \
${TMP}/usr/bin/*
- #back the build dur out of lib
+ #hack the build dur out of lib
perl -p -i -e "\
s'${TMP}-lib?''g;\
s'${TMP}(-webui)?''g;\
- " ${TMP}-webui/usr/local/etc/freeside/handler.pl \
+ " ${TMP}/usr/local/etc/freeside/handler.pl \
${TMP}-lib/usr/share/perl5/FS/*.pm \
${TMP}-lib/usr/share/perl5/FS/*/*.pm